http://www.jungol.co.kr/bbs/board.php?bo_table=pbank&wr_id=254&sca=10g0

 

JUNGOL | 구조체 - 자가진단5 > 문제은행

경기도 안양시 동안구 평촌대로 109 협성골드프라자 601호 TEL : 031-360-4144 FAX : 031-388-0996 E-mail : hancomc@hotmail.com, comkiwer@naver.com Copyrightⓒ 2010-2019 jungol. All right reserved. TOP

www.jungol.co.kr

 

 

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
/*
617 : 구조체 - 자가진단5
5명의 이름과 키를 입력받아 키가 가장 작은 사람의 이름과 키를 출력하는 프로그램을 작성하시오. 이름은 20자 이하이다.
입력 예
Park 175
Lee 180
Choo 185
Son 193
Kim 188
출력 예
Park 175
*/
typedef struct s{
    int num;
    char name[10],sub[10];
    int score[100];
}Student;

int main()
{
    int m[12],n=5,i,p=0,q=99990;
    //struct s stu[100];
    Student stu[100];
    //scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%s %d",stu[i].name,&stu[i].num);
    }
    for(i=0;i<n;i++)
    {
        if(q>stu[i].num){
            q=stu[i].num;
            p=i;
        }

    }
    printf("%s %d",stu[p].name,stu[p].num);
    return 0;
}

+ Recent posts