http://www.jungol.co.kr/bbs/board.php?bo_table=pbank&wr_id=252&sca=10g0

 

JUNGOL | 구조체 - 자가진단3 > 문제은행

두 명의 이름과 국어, 영어 점수를 입력받아 과목별 점수의 평균을 구하여 출력하는 프로그램을 작성해 보시오. (이름은 20자 이하이고 평균의 소수점 이하는 버림한다.)

www.jungol.co.kr

 

 

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
/*
615 : 구조체 - 자가진단3
두 명의 이름과 국어, 영어 점수를 입력받아 과목별 점수의 평균을 구하여 출력하는 프로그램을 작성해 보시오.
(이름은 20자 이하이고 평균의 소수점 이하는 버림한다.)
입력 예
Junho 88 100
Seonbin 95 96
출력 예
Junho 88 100
Seonbin 95 96
avg 91 98
*/
typedef struct s{
    int num;
    char name[10],sub[10];
    int score[100];
}Student;

int main()
{
    int m[12],n,i,p=0,q=0;
    //struct s stu[100];
    Student stu[100];
    for(i=1;i<=2;i++)
    {
        scanf("%s %d %d",stu[i].name,&stu[i].score[0],&stu[i].score[1]);
    }
    for(i=1;i<=2;i++)
    {
        printf("%s %d %d\n",stu[i].name,stu[i].score[0],stu[i].score[1]);
    }
    for(i=1;i<=2;i++)
    {
        p+=stu[i].score[0];
        q+=stu[i].score[1];
    }
    printf("avg %d %d",p/2,q/2);
    return 0;
}

+ Recent posts