http://www.jungol.co.kr/bbs/board.php?bo_table=pbank&wr_id=255&sca=10g0
#include<bits/stdc++.h>
using namespace std;
/*
618 : 구조체 - 자가진단6
5명의 이름과 키, 몸무게를 입력받아 이름순으로 정렬하여 출력하고,
몸무게가 무거운 순으로 정렬하여 출력하는 프로그램을 작성하시오.
몸무게는 소수점이하 1자리까지 출력한다.
입력 예
Lee 150 35.6
Kim 155 28.9
Sin 148 32.7
Jung 160 41.2
Park 165 38.7
출력 예
name
Jung 160 41.2
Kim 155 28.9
Lee 150 35.6
Park 165 38.7
Sin 148 32.7
weight
Jung 160 41.2
Park 165 38.7
Lee 150 35.6
Sin 148 32.7
Kim 155 28.9
*/
struct students
{
char irum[10];
int kee;
float mugae;
};
bool compare(struct students a ,struct students b){
return a.mugae<b.mugae;
}
bool compare2(struct students a ,struct students b){
//????
return strcmp(a.irum, b.irum) < 0;
}
int main()
{
int i;
struct students s[5];
for(i=0; i<5; i++){
scanf("%s %d %f",s[i].irum,&s[i].kee,&s[i].mugae);
}
sort(s,s+5,compare2);
for(i=0; i<5; i++){
printf("=name= %s %d %g\n",s[i].irum,s[i].kee,s[i].mugae);
}
sort(s,s+5,compare);
for(i=0; i<5; i++){
printf("=mugae= %s %d %g\n",s[i].irum,s[i].kee,s[i].mugae);
}
return 0;
}
'정보올림피아드-KOI > 기초 문법 문제' 카테고리의 다른 글
610 : 문자열2 - 자가진단9 (0) | 2020.03.14 |
---|---|
590 : 함수3 - 자가진단4 (0) | 2020.03.13 |
615 : 구조체 - 자가진단3 (0) | 2020.03.11 |
617 : 구조체 - 자가진단5 (0) | 2020.03.11 |
176 : 함수2 - 형성평가2 (0) | 2020.03.09 |